NFGT Round 2 Application Question


Joe Dozzo

Well-known member
Mark IV Lifetime
Le Mans 2010 Supporter
May 22, 2006
585
Anchorage AK / Golden CO
I've been able to successfully log into my account but am having trouble getting past the first page...

All my Applicant Info was successfully restored from my 2016 application. I select a language (English) and check the "All info is accurate.." box then Save & Continue.

This results in a "An error occurred. Please try again." above the Save box. There are no other warnings in the Applicant Info section. I can scroll through the rest of the application, update a few fields as necessary. Nowhere do I see any red text indicating missing or erroneous data.

I've even been able to update the "Your Style" section (just text, no video or picture links).

I can Save (twice) and the system reports the application was saved successfully. But that is not correct. I never get the confirming e-mail from Ford saying the update was successful and if I return to the application, any updates I entered are lost.

I've tried both Internet Explorer and Firefox Mozilla with the same result.

Anyone else experiencing anything similar?

I've been through this several times now and may be just missing something... Any suggestions?

Thanks All!
 

ChipBeck

GT Owner
Staff member
Mark IV Lifetime
Le Mans 2010 Supporter
Feb 13, 2006
5,369
Scottsdale, Arizona
Joe,

Try Google Chrome
 

Joe Dozzo

Well-known member
Mark IV Lifetime
Le Mans 2010 Supporter
May 22, 2006
585
Anchorage AK / Golden CO
Sadly, same behavior in Chrome...
 

GTED

GT Owner
Apr 4, 2006
768
Joe, I had same problem yesterday; I was pulling my hair... At the end, I decided that each time I "expand" each section to review or edit, I would re-click Save & Continue, and when I got to the final "submit" step, I expanded each and every one of of the previous section to re-click Save & Continue, before I clicked on Submit. With that, I finally rec'd a successful submit message. I know...., it was a bit confusing. Good luck!

Ed
 

Joe Dozzo

Well-known member
Mark IV Lifetime
Le Mans 2010 Supporter
May 22, 2006
585
Anchorage AK / Golden CO
Thanks, but so far no success at all.... I can't seem to get past the first "Applicant Info" section without getting the error message...

Maybe it needs a rest until Monday...
 

fjpikul

GT Owner
Mark IV Lifetime
Le Mans 2010 Supporter
Jan 4, 2006
9,819
Belleville, IL
If I remember correctly, the same thing happened initially due to the massive number of applications all at once. Be patient.
 

BtwoG

GT Owner
Dec 8, 2013
662
Atlanta, GA
Technical website questions can be sent to GTAPPSUP@ford.com
 

JOEA2

GT Owner
Mark II Lifetime
Aug 16, 2007
322
STATEN ISLAND,NY/SEA GIRT,NJ
I've been going back and forth with them for 24 hours over the same problem.

Joe
 

Joe Dozzo

Well-known member
Mark IV Lifetime
Le Mans 2010 Supporter
May 22, 2006
585
Anchorage AK / Golden CO
Maybe it only impacts "Joe"'s!

I'll send them an e-mail as well.
 

Special K

GT Owner
Mark IV Lifetime
Aug 23, 2016
860
Franklinton, LA
Technical website questions can be sent to GTAPPSUP@ford.com
I’m having trouble accessing my existing app from 2 years ago due to a change in the email address originally used. The GT app support has been working with me to correct the issue. If you’re still having an issue, send them an email. They are prompt at responding. Good Luck!


Sent from my iPhone using Tapatalk Pro
 

68Rcodeman

GT Owner
Mark II Lifetime
Apr 5, 2008
423
Spring Hill, FL.
I’m having trouble accessing my existing app from 2 years ago due to a change in the email address originally used. The GT app support has been working with me to correct the issue. If you’re still having an issue, send them an email. They are prompt at responding. Good Luck!


Sent from my iPhone using Tapatalk Pro
Kevin,
Two email addresses means two chances :wink Good luck to all applicants.
 

Gary

GT Owner
May 11, 2006
152
USVI & Lake of the Ozarks
I've updated mine about a dozen times and each time smooth as silk.
 

Joe Dozzo

Well-known member
Mark IV Lifetime
Le Mans 2010 Supporter
May 22, 2006
585
Anchorage AK / Golden CO
Congrats to the GT Applications Support team. Whatever issues I had are now successfully resolved.

JoeA2 - Hope you can now update your application as well.
 
Last edited:

JOEA2

GT Owner
Mark II Lifetime
Aug 16, 2007
322
STATEN ISLAND,NY/SEA GIRT,NJ
Ford fixed the problem yesterday and I was able to successfully submit it today. It took them a week but they didn't give up!

Joe