Close

Results 1 to 9 of 9
  1. #1
    GT Owner NorthwoodGT's Avatar
    Join Date
    Jun 2009
    Location
    Michigan
    Posts
    953

    Default TURN SIGNAL NOT WORKING

    I'm stumped on this one. emergency flasher works on both left and right, front and rear so we know it's not a wiring issue.
    Left front turn signal and rear left turn signal work fine. Right front and right rear turn signal- NOTHING. had the GEM out a couple times for other issues. a wire pulled out? multi-function switch? all worked fine before. it's not a ground or a battery issue.
    suggestions?? thanks
    Scott

  2. #2
    Le Mans 2010 Sponsor fjpikul's Avatar
    Join Date
    Jan 2006
    Location
    Belleville, IL
    Posts
    9,399

    Default

    Bad bulb?

  3. #3
    gt owner & supporting vendor
    Join Date
    Feb 2006
    Posts
    3,359

    Default

    Bad bulb?
    emergency flasher works on both left and right
    Maybe a SmartBulb, but not a bad bulb.
    Go to www.cooltechllc.com to see some "cool" GT products!

  4. #4
    Le Mans 2010 Sponsor fjpikul's Avatar
    Join Date
    Jan 2006
    Location
    Belleville, IL
    Posts
    9,399

    Default

    Isn't there more than one filament in the turn signal bulb up front?

  5. #5
    GT Owner NorthwoodGT's Avatar
    Join Date
    Jun 2009
    Location
    Michigan
    Posts
    953

    Default

    if the emergency flashers work, it's not the bulb
    Scott

  6. #6
    GT Owner PeteK's Avatar
    Join Date
    Apr 2014
    Location
    Great Falls, VA
    Posts
    825

    Default

    Scott, I havne't dug into the wiring diagrams yet, but I'm certain the turn and flasher lights are controlled through the SJB (smart junction box). They have to be, in order for the key fob to activate them when you remotely lock the car--speaking of which, when you lock the car with the fob, do the lights flash?

    Then I'd look closely at the turn signal switch. These do wear or fail. Fiddle with it and see if pushing harder or forward or backward whilst engaging the turn signal makes any difference. The turn signal switch is easy to get to. Back when I first bought my car and joined the list, I wrote up a procedure for removing the cowl around the steering wheel. My tilt-wheel lever adjuster had loosened and was not holding the adjustment very well. Anyway, two or three screws hold on the cowl halves, and then you can get to the connectors and turn signal switch. You can try to jumper around the switch and see if the turn signal activates.

    Next, I'd get into the wiring diagrams and see if there is a replaceable flasher for the right turn signals. Probably not, because the SJB most likely handles that function too. But the diagrams will give you the current flow and show where to check for continuity or signal and the wire color codes for jumping around the switch.
    Pete K

    Cars are for driving--if you want art, get something you can hang on the wall!

  7. #7
    GT Owner Johntpr's Avatar
    Join Date
    Jan 2017
    Location
    Rockland County, NY
    Posts
    63

    Default

    Maybe some of the diagrams from my thread may help you? See below. My issue wound up being the SJB, but a turn signal switch being bad can also be the culprit. They are cheap enough and easy to change.

    http://www.fordgtforum.com/forums/sh...imly-by-itself
    2006 Ford GT red with 4 options

  8. #8
    GT Owner FBA's Avatar
    Join Date
    Dec 2010
    Location
    31.022340 N / 44.846191 W
    Posts
    1,604

    Default

    Turn signal switch; mine failed on the high beam / low beam. I'd bet big it's that.
    2018 Lambo Huracan Performante
    2018 911 C4 GTS Cab
    2017 Sierra Denali 2500 6.6
    2016 Corvette Z06
    2016 911 TTS /695 HP/ 800 TQ
    2005 Yellow GT (in wrapper)
    2005 White GT /850 WHP



  9. #9
    *Supporting Vendor* GT Owner thegtguy's Avatar
    Join Date
    Apr 2006
    Location
    MI
    Posts
    458

    Default

    Quote Originally Posted by NorthwoodGT View Post
    I'm stumped on this one. emergency flasher works on both left and right, front and rear so we know it's not a wiring issue.
    Left front turn signal and rear left turn signal work fine. Right front and right rear turn signal- NOTHING. had the GEM out a couple times for other issues. a wire pulled out? multi-function switch? all worked fine before. it's not a ground or a battery issue.
    suggestions?? thanks


    Im inbetween a few cars. Bring it down next week. Should be able to figure it out.

    Rich Brooks
    The GT Guy LLC
    www.thegtguy.com
    734-658-9498
    richgtguy@gmail.com

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •